Older iPhones need this update immediately or GPS, email won’t work correctly, Apple says

Apple announced that owners of devices introduced in or before 2012 will have to … iPhone 5 users must install update 10.3.4 via wireless or computer by Sunday to keep the GPS, cloud, email, web …
Apple Computer – read more