Snow Leopard to support iCloud? – CNET Asia

Apple frequently saves its newest features for the latest versions … You will no longer be able to sync with this machine because you’ve upgraded to iCloud. iCloud requires a computer running Mac OS X Snow Leopard v10.6.9 or later for Contacts, Calendars …

Source:Snow Leopard to support iCloud? – CNET Asia

0 replies

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply